Forum Overview.com
Kategori: Lagring
Två diskar fallit ur min RAID 5!!
Fråga:
Jag hade en 5 diskar stark RAID 5 array för ett par timmar sedan. Jag tänkte jag skulle installera om Windows och stänger av RAID kontrollern i BIOS för att Windows skall hitta min BOOT disk. (Detta har jag gjort innan och det har aldrig varit några som helst problem) Men när jag installerat Chipset drivrutinerna (Nvidia Nforce 590 AMD) och satt igång RAID kontrollern i BIOS igen så fungerar inte RAID arrayen alls.

Jag har ett ASUS M2N32 SLI-Delux modekort med inbyggd RAID kontroller. I RAID BIOS står det att man kan göra en Rebuild men det är bara 3 av diskarna som visas. I Windows kan jag se alla både i Enhetshanteraren och i Nvidias eget program "Media Shield" (som även RAID BIOSen heter).

Jag behöver akut hjälp då jag har 900 Gb oersättlig information. Alla mina backuper låg på arrayen också (Klantjävel, jag vet) Jag såg till att ha en RAID 5 just ur säkerhetsperspektiv då det är minst chans att något skulle bli fel, men chi fick jag!

Finns det något sätt att lösa det här?
Hjälp uppskattas verkligen!!
Svaren i kort:
Oersättlig data bör man aldrig placera i en mjukvarubaserad raidlösning :| Om två diskar rasar i en RAID5 är man tyvärr shit out of luck.. kan det vara programvaran som signalerar fel? Kanske är det så enkelt som att du inte kör samma version av drivrutinerna till raidkontrollern som du gjorde innan du installerade om Windows? Det verkar ju helt osannolikt att två diskar ska gå sönder samtidigt just i samband med att du stänger av raidkontrollern. Nej, diskarna är säkerligen inte sönder. Jag kör exakt samma drivrutiner innan som nu (dock har det krånglat en hel del, därav anledningen till ominstallation) Dessutom så är det 5 st en månad gamla Samsung diskar. Det är helt omöjligt att de har gått sönder två på en gång.

Det hela är grovt mystiskt. Det började med att RAID BIOS sa till att det var fel, så allt är smått underligt...Kan det vara något annat i BIOS som ställt till det? Den inställningen var det ända jag ändrat på. Har haft liknande prob med mina mjuka femmor och i mitt fall berodde det på glappkontakt. Kolla i BIOS att du har alla diskar åtkomliga. Undersök diskstatus med S.M.A.R.T. Men nu blir jag lite förvirrad. Är inte kontrollern som är inbyggd i Mammakortet en hårdvaru baserad RAID? MjukvaraRAID är väll att man har ett program som gör RAIDen under OSet? (eller?) Jag har ju egen RAID BIOS och hela den biten...

Men i vilket fall!

Stänger jag av RAID kontrollern i BIOS så kan man se alla diskarna utan problem, den söker upp dem med "Auto" och de visas helt normalt i enhetshanteraren i Windows. Det är bara att de är utanför arrayen! (Va skall de där å göra?!?)

Vad skulle hända om jag tog bort RAIDen och gjorde om den? Går det att göra utan att ta bort all information på diskarna? Eller då försvinner alltihopa igen? *snaaark*

Det finns ju också "Rebuild" alternativet i RAID BIOS men det är fortfarande bara 3 diskar som ser ut att vara i den arrayen... citat:Ursprungligen inskrivet av anemic
Jag såg till att ha en RAID 5 just ur säkerhetsperspektiv då det är minst chans att något skulle bli fel, men chi fick jag!


Är det inte RAID 1 du skulle valt i säkerhetsperspektiv där?

Om det är "oersättlig information" så varför välja raid 5 då?

Var har du läst att det är minst chans med raid 5 att något skulle bli fel? 1. RAID har inget med backup att göra. RAID (ej 0) kör man för att vinna tid då en disk kraschar. Backup kör man på viktiga data för att dessa inte skall förloras när Herr Murphy kommer på besök.

2. Har du ett RAID-BIOS så är det en hård- eller chipset raid du kör. Därtill brukar det finnas ett adminprogg från leverantören som hanterar RAIDen.

3. Om inte alla diskarna syns i RAID-BIOS - kolla om du kan få in dem som medlemmar i arrayen igen utan omformattering. Innan dess borde du köra en rejäl diskdiagnos för att reda ut om dom är helt friska!

/jookeer citat:Ursprungligen inskrivet av jookeer
1. RAID har inget med backup att göra. RAID (ej 0) kör man för att vinna tid då en disk kraschar. Backup kör man på viktiga data för att dessa inte skall förloras när Herr Murphy kommer på besök.

Amen! RAID är för uptime, backup för datasäkerhet. Det är oroande att se hur ofta folk sätter likhetstecken mellan RAID och backup.

citat:Ursprungligen inskrivet av jookeer
2. Har du ett RAID-BIOS så är det en hård- eller chipset raid du kör. Därtill brukar det finnas ett adminprogg från leverantören som hanterar RAIDen.

För att förtydliga: Det man normalt menar med "hårdvaru-RAID" är att kontrollerkortet har en egen processor och RAM-buffert som sköter XOR-beräkningarna som krävs för paritetsdata i RAID5 (och dess varianter). Detta saknas på de flesta (för att inte säga alla) RAID-kontrollers som är integrerade på moderkort och även på de vanligaste RAID-korten för SATA i konsumentklassen. Därtill mjukfemmor som funkar överallt där du har minst 3 diskar. Gratis är gott men surseeegt att skriva till. Däremot är läsning OK. Ok, nu har vi kommit bort lite från ämnet här tycker jag...

Nä, oersättlig är inte informationen, men det är jäkligt närvöst att förlora den. Jag har gjort backup på det absolut viktigaste. Har en Backup dator och DVD plattor. Däremot ligger det en sörens massa som hade varit rena undret om jag hade kunnat återställa. Hade aldrig kunnat tänka mig att en ominstallation skulle kunna köra ner hela arrayen i botten!

Med RAID 5 så kan man åtgärda hårddiskkrasher (som jag har haft ett par stycken) snabbt och lätt, snabb läsning också. Visst hade en RAID 1 varit bättre, men då hade hälften av diskarnas utrymme gått åt. Nu gick bara en bort. Eller rättare sagt, allt gick bort...

Ja, som jag har skrivit innan så är det chipset som styr RAIDen. Jag har ett ASUS M2N32 som har Chipset Nforce 590. Det är Nvidias drivrutiner jag kör, vilka jag iofs har haft problem med innan, därav ominstallationen av Windows. Programet som styr allt genom Windows heter MediaShield.

När jag kommer hem skall ni få lite trevlia screenshots. Kanske någon som kan hjälpa mig eller i allefall säga om det är helt djäfla kört eller inte. Det är långt ifrån första gången man läser om icke-hårdvarulösningar (som NakedApe redan förtydligat definitionen för) baserade på Raid5 som resulterar i katastrof. Visst är det gott med gratis men hur dumsnålt känns det inte när 900GB med data hamnar i papperskorgen? Mitt förslag är att du handlar ett LSI Logic eller 3Ware kort på ebay, går att få under 2000kr inkl allt. Då får du ett riktigt stabilt raidkort med support (jo även på andrahandsköpta grejer) i proffsklass.

http://cgi.ebay.com/LSI-LOGIC-MEGAR...1QQcmdZViewItem Du förlorar väl allt om fler än en disk i en femma rasar oavsett hård eller mjuk?!

Jag har bytt ut alla diskar, en i taget, på mjuka femmor utan prob. Dock tog det 11 timmar resync per disk. Därtill haft glappkontakt på en annan femma som förorsakade oändliga ombyggningar. Trots detta har jag i dessa fall aldrig förlorat en byte.

Så det finns alltså de som lyckas med mjuka femmor också. Visst min poäng var att det oftast inte handlar om att två diskar verkligen går sönder utan att kontrollern i dessa lösningar helt plötsligt tycker att nåt är knas vilket ofta resulterar i att man verkligen tappar data. Jag har självt upplevt detta personligen när en av mina diskar listades med kapacitet 0 av min integrerade raidkontroller. Därefter blev jag ägare av ett LSI-kort och det inköpet ångrar jag inte för en sekund OK!

I helgen flyttade jag en mjukfemma (IDE/PATA) mellan 2 burkar - smärtfritt - plug'n'play - tog 1 timme att demontera/montera diskarna + 1 timme att patcha XP.

Som sagt, det finns för- och nackdelar med mjuk- resp hård femma. Raid 10 for the win....

Ok ok, så det finns typ inget att göra ändå.
Det är ju bara fördjäfligt helt enkelt... Alltså...vad ni än hävdar så... raid5 (eller någon form av raid) kanske inte ska ses som backup men för många så är det en tillräcklig säkerhet. Om inte annat så är det ju faktiskt mer säkert än att inte ha något alls.

Jag är inte helt hemma på moderkortskretsraid men vet du om diskarna står som Foreign i diskhanteraren? Om så, så ska de importeras vid nyinstallation av operativsystem. Jag skulle även önska att du kunde skriva lite mer...uh...korrekt (missförstå mig rätt nu) och utförligt för det är svårt att förstå vad du menar. "Utanför arrayen" säger absolut ingenting.

Sedan så undrar jag om diskarna sitter på olika kontrollerkort, typ nForce590 och SiliconImage, i sådana fall kommer du behöva drivrutinerna till båda innan alla diskar dyker upp i Windows.

Och till slut, kan det vara ditt nätaggregat som gör att du tappar diskar? Det är väldigt onormalt att man tappar dem om de inte är trasiga från början. Som jookeer säger, glapp kan också vara en anledning. Ok, nu kan jag inte klistra in bilder här tyvärr men jag skall försöka förklara igen.


Det är ett Nforce590 Chipset som sitter på bordet. Alla diskarna är kopplade till den kontrollern. Silicon Image sitter helt annorlunda och är bara konfad för att vara en SATA kontroller.

Mitt nätagg är ett Cooltek 600W agg som (skall vara) bra. (Vann ju trots allt testet här på SweClockers). Jag har kollat och dubbelkollat alla kablar och strömkontakter. Allt har fungerat fram tills ominstallationen.

Nu har jag RAID kontrollern AV i BIOS. När jag går in i enhetshanteraren så finns alla diskarna där. Mina fem samsung diskar och min Raptor som då är OS disken.

När jag nu går in i Diskhanteringen så vill den att jag skall konvertera diskar som nu hittas. Då vill den att jag skall initera DISK 3 och sen konvertera DISK 3 & 5. Jag kör cancel där för jag vill inte röra till det mera.

Nu står det då C och E (Raptor disken, DISK 0) är helt ok.
Också D: (DISK 1) står (som innan var min RAID partition) att den är ok, men bara då 232 Gb (vilket bara är en disk så det stämmer inte)

DISK 2 står som Främmande
DISK 3 står som Okänd, inte allokerat utrymme
DISK 4 står som Främmande
DISK 5 står som Okänd, inte allokerat utrymme

Hade alla tillhört en array borde ju alla stå som Främmande?

Ok, det är när den är AV. Nu sätter jag igång RAID kontrollern i BIOS (Enable RAID). Sen så anger jag vilka SATA kontakter som skall vara tillgängliga för RAID. Yezbox!

Till att börja med så under BOOT så brukar det stå 950 Gb RAID 5 array Ok. Men nu blinkar det rött och säger att den inte fungerar.

Jag går in i RAID BIOSen och tittar.
När jag gjorde RAIDen för ett tag sedan så gick jag bara in, satte att jag ville ha alla mina 5 diskar och så var det i princip färdigt.
Nu när jag går in och tittar på arrayen så finns det bara tre diskar som tillhör den. De andra två skulle jag om jag ville kunna sätta in i en ny RAID. De är tillgängliga för hantering.

Yiha, ut i Windows igen. Då säger mitt RAID hateringsprogram, Media Shield att det finns två diskar tillgängliga för hantering. Mycket riktigt så finns det två stycken som inte är tilldelade någon RAID. I Media Shield ser jag även att jag har en RAID 5 men det är bara 3 diskar i den.
Två stycken har alltså "fallit ur" min array. Mycket underligt må jag säga...

Ok, hoppas det här hjälper någon att hjälpa mig ; )
Är det något oklart så kan jag beskriva det ytterligare (hoppas jag).
Hade ju varit fantastiskt kul att få det att fungera igen. Alla diskarna tycks ju vara friska och identifierbara av Mediashield. Utgår ifrån att du kört diagnoserna och kollat S.M.A.R.T.

Nu har jag inte erfarenhet av Mediashield på 590 men skulle tro att du kan ange de diskar du saknar som medlemmar i arrayen. Han borde varna innan han skriver på diskarna så du kan ångra dig om du är osäker.

Tyvärr är det mycket sällsynt att swecare kör femmor så försök med amerikanska sajter.

Skulle läsa manualen i ditt fall och googla efter andras erfarenheter för att samla in så mycket fakta det går. Jag vet inte om jag är trött, men enligt manualen till nVidias raidlösningar http://us.download.nvidia.com/Windo...Shield_UGv5.pdf

så står det på sidan 8 att under menyn Integrated Peripherals så ska Raid Enable vara Enabled för att det ska fungera. Kontrollera att alla diskar har Enabled som status också. Kan kanske vara därför de står som Okända.

Och till slut står det på sidan 22 att du under Windowsinstallationen måste trycka på F6 för att installera nvidias Raiddrivrutiner men det har du gjort antar jag.

Jag gissar att det är okay att Initiera en disk, däremot att konvertera den låter farligt. Jag har som sagt satt att RAID skall vara Enable i min BIOS. Alla de aktuella diskarna är Enablade för RAID.

Under min Windowsinstallation så disablade jag RAIDen för att Windows inte hittar min Raptor disk som sitter själv om den är ingån. Har ingen floppy så jag tänkte att det var de lättaste att göra. Jag har slått på och av RAIDen innan utan några som helst problem.

Är RAID biosen och drivrutinerna i Windows sammankopplade på något sätt? Kan det vara så att det är Nvidias drivrutiner som är knas och orsakar fel? Är inte drivrutinerna bara till för att Windows skall känna igen saker och ting i Windows?

Vad skulle hända om jag tog bort arrayen och gjode om den, utan att köra "Clear Disk"? Går det?
Borde den inte strukturera upp det som det var innan då?

Gaaaah, blir tokig! Har lagt upp frågon på både Nvidias och ASUS forum utan svar. Sökt på nätet så fingrarna blöder, men jag har inte hittat någon som haft samma problem direkt och löst det.
Knepigt de här! Men det är bara att fortsätta leta...

Man skulle inte kunna utvinna informationen om man kör ett "Disk Recovery" program som t.ex Winternals Admin Pac? Det har jag faktiskt lyckats få tillbaka en hel HD där partitionen hade gått åt pipan på. Nej du får inte ut ett smack vettigt eftersom diskarna tillhörde en raid, tyvärr. Proffs däremot kan få fram all "oersättlig" info men jag misstänker att du Anemic inte vill eller är villig att betala priset... Nädu, jag har skickat iväg en disk innan till ett företag i Norge. De tog 30.000:- för jobbet men kunde inte få fram ett jöte ändå...
Priset utan information blev dock "bara" 10.000:- Tidigare skrev du

citat:Nu har jag RAID kontrollern AV i BIOS.

därav min undran.

citat:Under min Windowsinstallation så disablade jag RAIDen för att Windows inte hittar min Raptor disk som sitter själv om den är ingån. Har ingen floppy så jag tänkte att det var de lättaste att göra. Jag har slått på och av RAIDen innan utan några som helst problem

Tror du har problemet där. Om jag ska installera Windows på min systemdisk i WS i sign så måste jag också sätta i en diskettstation (det sitter iofs en permanent där), annars syns bara mina lagringsdiskar och inte den enskilda systemdisken. Lite ologiskt kanske men så är det hos mig iaf. Men jag kör ju inte fuskhård raid5a utan mjuk rakt igenom.

Däremot är det ju inga problem att, som du säger, slå på och av en raid5a. Men det verkar som att den behöver finnas vid Windowsinstallationen för att det ska fungera som det ska. För mig lägger installationsprogrammet en liten mapp på raid5an som innehåller en cache eller något liknande på 8-10mb.

nVidias drivisar är nog inte knas, nej.
Med kontrollerstyrda raid5or så "kan" man i regel flytta en uppsättning mellan olika datorer så länge det är samma kretsar på moderkortet.

Håll mig dock inte skyldig för eventuell dataförlust här.
Precis som superboss säger så blir det problem med att få tillbaka data genom ett recoveryprogram när det ligger på en raid5a. Jag har provat, visst filerna ser ut att finnas där men de funkar inte. Gjorde en recovery på ett metallicagig, resultatet blev någon blandning av Metallica, Sarah Brightman och Leonard Cohen... Nu hittade jag en annan lite underlig sak. Jag läste igenom manualen lite innan men hittade inget speciellt.
Men nu när jag var inne i RAID BIOS igen och tittade så ser man att de 3 diskarna som sitter i RAID arrayen heter 1.1, 2.1 och 3.1. Men de diskarna som är utanför, de heter 2.0 och 3.0.
Enligt manualen så är det första nummret Adaptern och de andra är kanalen. I mitt fall så verkar det inte stämma för då skulle jag ha 5 olika adaptrar. Verkar mer som om det är den andra siffran som är adaptern, altså 0 och 1 här. Kan det ha blivit något så konstigt så datorn tror det är två olika adaptrar??

Ok, men då gör jag så här. Imorrn provar jag att göra som du säger. Sätter in en floppy, gör drivrutiner och kör om allt från början med drivrutinerna redan i Installationen av Windows.

Jag tänkte även prova att byta ut de två diskarna som ligger utanför arrayen med nya och se om det är en av dem som helt enkelt har gått sönder och behöver bytas ut. De borde ju inte vara två stycken på en gång, ganska osanolikt. Men det kan ju vara att en strular och då drar den ner den andra också...på...något konstigt sätt!
Men jag är villig att prova det mesta så vi kör på det!


UPPDATERING 11:40 29 December 2006!

Ok, jag provade att installera om hela datorn (igen) men den här gången med diskett med drivrutiner på. Det löste tyvärr inget alls. Men jag undrar fortfarande hur det kan komma sig att de har olika nummer på de som är utanför arrayen och de som just nu sitter i.

Vad skulle hända om jag kör Rebuild i RAID BIOS? Skulle den bara försöka köra in de tre diskarna som finns de eller den kanske letar upp de två andra diskarna också?
Gå till forumet

del.icio.us:Två diskar fallit ur min RAID 5!!   digg:Två diskar fallit ur min RAID 5!!   spurl:Två diskar fallit ur min RAID 5!!   wists:Två diskar fallit ur min RAID 5!!   simpy:Två diskar fallit ur min RAID 5!!   newsvine:Två diskar fallit ur min RAID 5!!   blinklist:Två diskar fallit ur min RAID 5!!   furl:Två diskar fallit ur min RAID 5!!   reddit:Två diskar fallit ur min RAID 5!!   fark:Två diskar fallit ur min RAID 5!! blogmarks:Två diskar fallit ur min RAID 5!!   Y!:Två diskar fallit ur min RAID 5!!   smarking:Två diskar fallit ur min RAID 5!!

Relaterade länkar:
Nästa om Lagring

Föregående om Lagring